cooling fan nightmare!!

Post information for engine swaps, transmission swaps and anything else that covers engine and driveline information.
Post Reply
jdmpr
Wagoneer
Posts: 2
Joined: Thu Jan 22, 2015 8:21 am

cooling fan nightmare!!

Post by jdmpr » Thu Jan 22, 2015 9:00 pm

I recently bought a 91 lx wagon 5 speed and just a few weeks ago I noticed the coolant reservoir is boiling, kinda weird because the temp gauge reads fine, I went to inspect and noticed that the fans where connected straight to the battery. So I decided to fix this problem and now im stuck with no clue. So I wired the fans back to how they were supposed to be and connected each fan to the battery to see if they were still good, the cooling fan turned on but the a/c fan is broke. I did the paperclip deal to test the fuse and the cooling fan came on. So it must be the fan switch or the thermostat, so I replaced both, and I also replaced the top fan switch for good measure, nothing..... I spoke to a friend of mine and he told me it could be the ECU. Other than that im stuck.

User avatar
wagon97
Wagon Apprentice
Posts: 59
Joined: Mon Jul 25, 2011 8:51 am
Location: NJ

Re: cooling fan nightmare!!

Post by wagon97 » Sun Jan 25, 2015 11:50 am

Do you have schematic you can post. When you did paper clip thing do you mean you stuck it in fan switch. Hopefully not the fuse socket. I think the fan switch and the ECU both have the ability to turn the fan on. So yes it could be turning on when the fan switch calls for it to. Then not turning on when the ECU calls for it to. Not familiar with your year though but probably the same. But it could be wiring to ECU and not unit itself.

Post Reply