Engine revving too high.

Post any known problems with the 5th Gen Accord Wagon here.
User avatar
Inetba
Ruler of Wagons !
Posts: 1197
Joined: October 16th, 2008 10:54 AM
Location: Olathe, KS

Re: Engine revving too high.

Postby Inetba » October 26th, 2011 02:43 PM

Which part would I be checking for leaks? The whole thing?

User avatar
Inetba
Ruler of Wagons !
Posts: 1197
Joined: October 16th, 2008 10:54 AM
Location: Olathe, KS

Re: Engine revving too high.

Postby Inetba » November 23rd, 2011 11:42 AM

Took it to a shop a couple days ago, turns out it was the Torque converter solenoid. Go figure. Runs like a top again so I'm glad I took it in.

User avatar
bornmad
Come on.. Ask me a Wagon Question
Posts: 237
Joined: November 10th, 2009 02:44 PM
Location: Denver, CO

Re: Engine revving too high.

Postby bornmad » November 23rd, 2011 12:38 PM

Inetba wrote:Took it to a shop a couple days ago, turns out it was the Torque converter solenoid. Go figure. Runs like a top again so I'm glad I took it in.



Just so i understand you. When you take your foot off the gas when you are going 75mph. The rpms now drop to +/- 750 rpms?
Dr. Daze!
Rolling Around Denver, CO
*** 2012 TSX Wagon ***

User avatar
Inetba
Ruler of Wagons !
Posts: 1197
Joined: October 16th, 2008 10:54 AM
Location: Olathe, KS

Re: Engine revving too high.

Postby Inetba » November 23rd, 2011 01:59 PM

Do you mean it drops down to the normal idle? Or do you mean the revs drop 750 rpm?

User avatar
Mx-rep
Come on.. Ask me a Wagon Question
Posts: 335
Joined: September 13th, 2009 09:17 PM
Location: North Texas

Re: Engine revving too high.

Postby Mx-rep » November 23rd, 2011 04:33 PM

So did the computer shoot you a "check engine " code?

User avatar
Inetba
Ruler of Wagons !
Posts: 1197
Joined: October 16th, 2008 10:54 AM
Location: Olathe, KS

Re: Engine revving too high.

Postby Inetba » November 23rd, 2011 04:44 PM

Nope, no check engine codes which was odd.

globalexplorer
Wagoneer
Posts: 4
Joined: December 1st, 2012 11:55 PM
Location: Indianapolis

Re: Engine revving too high.

Postby globalexplorer » December 8th, 2012 09:35 AM

Mine was doing the same thing, I bought a can of throttle body cleaner and sprayed the daylights out of the throttle body intake and the problem went away. Dirty, sticky.
Sorry, new guy here, was here a year ago but then forgot my password and finally figured it out.
Paco
Indianapolis, In

CDelgado
Ruler of Wagons !
Posts: 1729
Joined: July 26th, 2008 10:56 PM
Location: Fremont,CA

Re: Engine revving too high.

Postby CDelgado » December 22nd, 2012 08:25 PM

Global - that sounds like a bad FITV I would take it out
& clean it or rebuild it.
Positive transaction:MF Baker, jarhead293, vinelandpd,da9b16, slowagon, Brain'sWagon, jack_lee,5THGENCREATION, RANDALL, INDAKA1, ovh3, theycallmesdz,SilverShadow

http://www.accordwagonclub.com/profile.php?id=8795